mozillaZine

Fanzine sur Mozilla et ses logiciels (Firefox, Thunderbird, SeaMonkey, etc.) — Site indépendant depuis 1999

dimanche 2 août 2009

Mozilla Firefox 3.5 sous Ubuntu

Alors que Firefox 3.5 est sorti depuis plus d’un mois, les utilisateurs de la distribution Linux Ubuntu 9.04, connue sous le nom de code Jaunty Jackalope, utilisent toujours la branche 3.0 de Firefox, ce qui est normal puisque la sortie d’Ubuntu 9.04 date d’avril 2009, soit deux mois avant la diffusion de Firefox 3.5. Pour les utilisateurs d’Ubuntu qui veulent utiliser la dernière version de Firefox plusieurs alternatives existent, la première étant bien entendu de télécharger l’archive 32 bits officielle générique à toutes les distributions Linux proposée par Mozilla, cette méthode présente quelques inconvénients, dont le principal est de ne pas proposer de binaire 64 bits.

Des alternatives existent, une d’elle est d’installer tout simplement le paquet « firefox-3.5 », soit en mode console en tapant la commande « aptitude install firefox-3.5 », soit en utilisant le gestionnaire de paquets Synaptic et de chercher le paquet « firefox-3.5 ». Le paquet « firefox-3.5 » est disponible dans le dépôt « universe » d’Ubuntu. Bien que le dépôt « universe » soit donné par Ubuntu sans aucune garantie de correctifs et de support, c’est en fait le même mainteneur d’Ubuntu qui s’occupe des paquets de Firefox 3 et Firefox 3.5. D’ailleurs la mise à jour de sécurité 3.5.1 a bien été proposée par le système de mise à jour d’Ubuntu, preuve que des mises à jour sont bien disponibles sur ce paquet. Par contre, le navigateur porte encore le nom de code de développement « Shiretoko », et ne possède pas l’icône de Firefox. Cette version de « Shiretoko » n’est pas en langue française, une solution est d’installer le paquet XPI proposé par FrenchMozilla, qui ne constitue par une localisation complète mais reste acceptable. L’avantage d’utiliser ce paquet est bien sûr la simplicité d’installation, de pouvoir conserver les deux navigateurs Firefox 3.0 et Firefox 3.5 (avec deux profils séparés), et de profiter des mises à jour globales du système d’exploitation. Mais c’est aussi d’avoir une version de Firefox bien intégrée au système Ubuntu, proposée à tous les comptes utilisateurs simultanément et surtout de profiter d’une version compilée en 64 bits pour les utilisateurs de plus en plus nombreux d’Ubuntu sur des machines 64 bits.

Pour terminer, il existe également des paquets Debian de différents logiciels Mozilla, comme les versions de développement de Firefox 3.5, Firefox 3.6 ou Thunderbird 3, disponibles sur les dépôts Personal Package Archives d’Ubuntu. Les PPA sont une solution proposée par Canonical, la société commerciale soutenant le projet Ubuntu, qui permet à un utilisateur ou une équipe de déposer des paquets sources Ubuntu qui seront construits et publiés en tant que dépôts APT par Launchpad. Attention cependant ces paquets proposés par ces utilisateurs ou ces équipes ne sont pas certifiés par Ubuntu. Comprendre par là que l’existence d’un paquet sur les PPA de Launchpad ne certifie pas de la bonne foi du mainteneur du paquet. Installer des paquets donne des droits d’administrateurs sur le système d’exploitation au paquet pendant sa phase d’installation et un développeur peu scrupuleux pourrait en profiter. L’équipe « Ubuntu Mozilla Daily Build » met donc à la disposition des utilisateurs d’Ubuntu les dernières versions de développement. Pour pouvoir installer ces versions de développement, un dépôt doit être ajouté et la clé publique importée soit par l’outil graphique Synaptic, soit via un terminal. Pour les utilisateurs d’Ubuntu 9.04, il est plus rapide d’ouvrir un terminal et de taper « sudo gedit /etc/apt/sources.list » et d’ajouter la ligne « deb http://ppa.launchpad.net/ubuntu-mozilla-daily/ppa/ubuntu jaunty main » tout à la fin du fichier et de sauvegarder et quitter l’éditeur de texte gedit. Puis d’importer la clé « Launchpad PPA for Ubuntu Mozilla Daily Build Team » (si vous estimez que vous pouvez faire confiance à l’équipe) en tapant « sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 247510BE », de lancer la commande « sudo aptitude update » pour mettre à jour les paquets. Puis d’installer un paquet en tapant une commande « sudo aptitude install », par exemple la commande « sudo aptitude install thunderbird-3.0 » installera Thunderbird 3 bêta 4.

(0) (0)

11 commentaires

  1. sonny dit :

    edge.launchpad.net/~ubunt... ne pas l'oublier...

    (0)(0)
  2. Bonjour Pause Choco 🙂

    Vous avez écrit: «Alors que Firefox 3.5 est sorti depuis plus d'un mois, les utilisateurs de la distribution Linux Ubuntu 9.04, connue sous le nom de code Jaunty Jackalope, utilisent toujours la branche 3.0 de Firefox, ce qui est normal puisque la sortie d'Ubuntu 9.04 date d'avril 2009, soit deux mois avant la diffusion de Firefox 3.5.»

    Justement, je ne trouve pas cela "normal"... Je trouve même que c'est une situation assez ridicule. Le problème principal, à part le fait de ne pas avoir Ff à jour est que l'on trouve un peu partout sur la Toile et des bidouilles d'installation ± correctes... si bien que j'ai publié un billet pour essayer de clarifier la situation climenole.wordpress.com/2...

    Je me pose une question: les gens de Mozilla et de Canonical/Ubuntu ne se parlent pas ou quoi? Ne trouvez-vous pas que ce serait bien que les deux fondations travaillaient ensemble au lieu de s'ignorer (mutuellement?) ? Juste une idée comme ça...

    Bonne journée. 🙂
    --
    Claude LaFrenière [climenole]: [{p ? ¬p}W{p ? ¬p}]
    Profil & Contact: www.google.com/profiles/c...

    (0)(0)
  3. lordphoenix dit :

    J'ai du mal à comprendre la logique des développeurs sur ce coup. Ils passent du temps à maintenir un ppa pour la version de développement mais ils ne le font pas pour la version stable!
    Très étrange logique…

    (0)(0)
  4. Pause Choco dit :

    Claude, oui j'ai écrit c'est normal à mon sens. Ubuntu ne va pas reconstruire entièrement une version passée d'Ubuntu dès qu'un nouveau logiciel sort. Surtout q' Ubuntu sort une version tous les six mois, donc il est plus que probable sur la Ubuntu 9.10 qui sortira dans trois mois proposera la version 3.5 de Firefox. Firefox 3.0 est parfaitement à jour, dans le sens où il sera encore maintenu plusieurs mois par Mozilla et Ubuntu et convient parfaitement à un utilisateur lambda pour une utilisation normale du Web.

    L'installation de Firefox 3.5 des dépôts « universe » n'est pas une bidouille, c'est un procédé facile et sûr. Même si la version se nomme « Shiretoko » et est en anglais, se sont bien les sources finales de Firefox 3.5.1 qui sont patchées et compilées par un développeur d'Ubuntu pour les architectures 32 bits et 64 bits.

    À mon humble avis, les développeurs de Mozilla se concentrent plus sur le code lui même, et la version Windows de Firefox qui doit représenter la grande majorité d'utilisateurs de leurs logiciels. N'oublions pas le monopole de Microsoft sur le poste client doit malheureusement encore dépasser les 90 %. Il existe de nombreuses distributions Linux, sur de nombreuses architectures, et Mozilla pour l'instant ne souhaite pas allouer des ressources pour adapter et réaliser des paquets pour chacune. En plus la façon de fonctionner des distributions Linux que ce soit Debian, Ubuntu, Fedora, ou autre est de récupérer les sources des logiciels « en amont », de patcher, d'adapter, de compiler les sources pour leur distribution. C'est un travail que les développeurs des distributions réalisent parfaitement, mieux que pourrait sûrement le faire Mozilla.

    (0)(0)
  5. Tutur dit :

    Petit soucis toutefois pour les 64bits, le xpi de "francisation" n'est pas compatible, dommage.

    (0)(0)
  6. Pause Choco dit :

    Non Tutur, le paquet XPI proposé par FrenchMozilla est bien compatible avec le paquet « firefox-3.5 » proposé dans le dépôt « universe ». Je viens de tester à l'instant sur mon Intel Core2 Duo 64 bits sous Ubuntu 9.04. Vous avez dû installer le paquet « firefox-3.5 » provenant du dépôt PPA d'« Ubuntu Mozilla Daily Build », qui bien qu'il soit toujours issu de la branche « firefox-3.5 », est en fait une version de développement estampillée en version 3.5.3. Alors que paquet « firefox-3.5 » proposé dans le dépôt « universe » porte bien le numéro de version 3.5.1 comme celui du paquet XPI proposé par FrenchMozilla.

    (0)(0)
  7. jmax dit :

    il y a de petits ajustements à faire pour que tout soit nickel.
    tout peut se faire en tapant about:config
    il est préférable de changer le nom du logiciel de Shiretoko en Firefox afin que certain sites comme Facebook ne limite pas les possibilités.
    Autres soucis, par défaut, tout est paramétré en en_US et donc les sites croyant à un utilisateur américain propose par défaut les sites en anglais. Un remplacement par fr et tout fonctionne comme un Firefox 3.0 venant de la distribution

    (0)(0)
  8. Boyouss dit :

    J'ai fait
    aptitude install firefox-3.5

    Resultat:
    Impossible de trouver un paquet dont le nom ou la description correspond à « firefox-3.5 »

    Ou est ce que je trouve un moyen simple d'avoir cette version?

    (et non la 3.0, dispo par synaptic ou adept)... Genre un pti .deb ce serait cool. Parce que les archives .tar.gz2, pour un nouveau, c'est... un casse tete!

    (0)(0)
  9. Pause Choco dit :

    Sous quelle distribution êtes-vous Boyouss ? Un paquet « Firefox 3.5 » est bien disponible Ubuntu 9.04 dans le dépôt « universe » d'Ubuntu. Le dépôt « universe » d'Ubuntu est normalement configuré par défaut à l'installation. Voir le lien suivant qui atteste l'existence de ce paquet : packages.ubuntu.com/jaunt...

    Je viens de refaire le test :
    aptitude update
    aptitude install firefox-3.5

    (0)(0)
  10. axilien dit :

    Salut, pour moi aussi impossible de le mettre en Français, le paquet n'est pas valable!!!

    (0)(0)
  11. axilien dit :

    Re voilà c'est ok je l'ai trouvé chez doc.ubuntu-fr.org/firefox

    (0)(0)

Les commentaires sont fermés.

^